Jump to content
tougekid1

steering wheel off center after turning.

Recommended Posts

I'm running the ebay poly bushings for the x7 and didn't have any problems with them until I wrecked haha

Share this post


Link to post
Share on other sites

I called rich on Tuesday, he sent me revised bushings, should be home today.. They are trying to find a happy medium, because only some of us are having the problem, while others are not...

 

I'll try to keep you guys posted.

Share this post


Link to post
Share on other sites

I emailed them yesterday. If I don't hear anything by Wednesday next week Il give them a call.

 

Demesio; I am eagerly awaiting your review of the revised bushing version!

Share this post


Link to post
Share on other sites

I;ve personally tested all version of the bushing. These guys are working their asses off to make a perfect solution trust me.

Share this post


Link to post
Share on other sites

I put some eBay urethane bushings on a customers car they worked good , only took a few minutes to install and they were only like 40 bucks shipped . I'm planning to build a tubular cross member with a IS300 or GS300 steering rack and tension rods like a 240 for my car .

Share this post


Link to post
Share on other sites

Just got a chance to look at this shit, and I won't be able to take the car apart for a couple of more days. I thought I could wiggle the rack off and have this done asap, but I'll have to drop the cross member to make this happen.

Share this post


Link to post
Share on other sites

I called Rich on Friday. He said to wait a month or so and call again and he should have a definite solution by then. Guess i'm on the wrong end of the country to help with testing..

Share this post


Link to post
Share on other sites

I just received an email from Rich at XM.

Says they are trying to pinpoint the issue as they have 3 cars there and only one is experiencing the same identified issues.

He goes on to say they are tightening up the tolerances but may need to go even tighter.

 

So it maybe a lil bit before we get any solution to the issue.

Personally I think there might be differences in racks. Like the casting in year 198X is a little thinner then the year 198X. But fuck If I know to be honest. Just looking forward to the solution.

Share this post


Link to post
Share on other sites

Can I slight thread jack real quick?

What boots are you running on x7 racks with x8 tie rods? I keep ripping (after installation) anything I put on.

Share this post


Link to post
Share on other sites

Bros.

 

My car's on-center position also changes drastically after turning. The wheel can feel dead for up to 1/3 of a full turn sometimes. It pretty much sucks. I have the xcesssive X7 rack to X8 bushings, but there does seem to be a bit of a fit issue? Or maybe it's a dead rack. I'm not totally sure.

 

I'll try and lift the car this weekend, and report back.

Share this post


Link to post
Share on other sites

Mark was right, it actually took me 30 minutes to install, car feels good as new. We shall wait and see if it stays that way. I think i had a bit of fault in the failing of the bushing... any of you running big tires and rubbing?

Share this post


Link to post
Share on other sites

The bushings shouldn't fail for ANY reason, other than fire...........

Share this post


Link to post
Share on other sites

If you watch the braided line and rack boot, you can see the rack move almost an inch in my video:

 

 

Bolts are tight, rack is loose! I do think the bushings are not perfectly sized.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×