Jump to content
Sign in to follow this  
Guest OrlandoGTE11211

Most Stupid Question Ever...

Recommended Posts

Guest OrlandoGTE11211

I just replaced my fuel pump with a Walbro 255 and I'm getting the same result I got before,I pulled ignition fuse and turned it over..I had no fuel on my plugs,they were dry. Now I am looking for the fuel pump relay... I can not fucking find it,checked under hood fuse box,driver side foot panel..I have no idea were it could possibly be. Or is there a fuse for the pump itself somewhere in the car that I'm not looking?

Share this post


Link to post
Share on other sites
Guest OrlandoGTE11211

I had my friend next to my tank when I turned the key,and he didn't hear anything from the walbro,but the orginal pump you didn't hear shit either. So I'm trying to figure out what the fuck it could be.Thats why Im looking for the relay now. But it's not under the hood because the only one I see is EFI main thats related to the fuel system and thats for injectors I believe. Want me to take a picture and show you guys?

Share this post


Link to post
Share on other sites
Guest OrlandoGTE11211

http://mail.aol.com/...=Inbox&partId=0

<br>

http://mail.aol.com/...=Inbox&partId=0

The first picture is the fuse box located under the hood and the second picture is a diagram of all the boxes on all-data. I can't find this shit.It's really getting me aggravated because I just wasted two hours replacing my pump to still have no results. I mean granted I needed to change the stock pump because my setup would have killed it eventually but I'd like to get back to driving my car lol.

Share this post


Link to post
Share on other sites

Fuel pump relay should be in the passenger side kick panel iirc.

 

I'm starting to think you're the greatest troll ever. Get a factory service manual for your car and stop asking cheese dick shit. If you aren't trolling us, you'll do great with the wealth of knowledge the electrical wiring diagrams will provide.

Share this post


Link to post
Share on other sites
Guest OrlandoGTE11211

Found it,it was located behind the passenger foot panel,which isn't even a panel..

Share this post


Link to post
Share on other sites
Guest OrlandoGTE11211

Sorry,just normally on cars the fuel pump relay is located under the hood.I was looking for a while.I have to order a service manual because none of the auto stores around here actually have one for the cressida =(

Share this post


Link to post
Share on other sites
Guest OrlandoGTE11211

So the relay was not my problem,I bench tested it,as well as my old fuel pump(Which wasn't the issue either..).So I was stumped after I installed the pump and had the same results,it turns out that the owner before me wired a kill switch to the fuel pump directly...And he kind of ghetto twist connected the wires and they fell apart. SOOO I reconnected them with a butt connecter and the car fired right up without any problems,also I managed to install my speedo cable extension elbow,which may I add was also a success considering I was about half a inch away from being able to install the speedo cable from the stock cressida to begin with. Tomorrow,Manual Boost Controller,Oil Catch can and possibly trying to diagnose my ABS light.Here's a video of me test driving it, I dont want to really give it full throttle until I get it tuned. Excuse my shaky video, I was trying to look at the road and send that video to my friend to show him that my speedo now worked.

 

@Whore Mouth - That pump is very loud by the way.

 

[media=]

[/media]

Share this post


Link to post
Share on other sites
Sign in to follow this  

×