Jump to content
Sign in to follow this  
Guest LuxurySlider

Building my shit thread

Recommended Posts

Guest LuxurySlider

So i finally got all my pictures uploaded, so i thought i would share my build with

you guys. I picked this thing up with a sloppy, leaky 5m and figured i needed to get it the

fuck out before i go broke from just buying oil.

 

This is what it looked like when i got it with the stock 5m.

6893586868_20dcccf555.jpg

rear by msw1991, on Flickr

6893586626_7919e84ddb.jpg

hid by msw1991, on Flickr

 

Car sat for a few months while i waited to get some cash saved up so i could buy my friends 2jz that

he pulled out of an 93 Aristo. Got an R154, lightweight flywheel, spec stage 3 clutch, bellhousing, and xccessive mounts so i could @ least get the motor in..

7039681495_4aff5c39e5.jpg

bay3 by msw1991, on Flickr

7039681113_f33586e2b7.jpg

bay by msw1991, on Flickr

Then beat the shit outta the firewall to get the twins to fit.

7039683049_41c5aa9848.jpg

twins by msw1991, on Flickr

Got the fmic deliverd and that just got mounted.

7039686663_43f01bce0d.jpg

imagejpeg_2_7 by msw1991, on Flickr

7039686797_5f2236b2bc.jpg

imagejpeg_2_8 by msw1991, on Flickr

 

Now this week im pulling the motor back out to clean up the engine to get ready for seals and also sanding the shit outta the bay for painting.

Share this post


Link to post
Share on other sites

Sup dude, this is Dustin, the chickenfucker that bought the 5m and w58 over the weekend.

 

Good luck on the car, that's a long, dark, road!

Share this post


Link to post
Share on other sites

Why you put the intercooler where it gets zero flow?

Share this post


Link to post
Share on other sites
Guest Gaijin Smash Wayhoff

Kyle, everyone knows intercoolers are just for looks...

 

Should be fun when it's done. Looks like a nightmare in the engine bay right now.

Share this post


Link to post
Share on other sites
Guest LuxurySlider

Well that's the only intercooler I could find with center outlets and the right dimensions.

Thinkin I need to cut some incognito holes in that bumper there.

Share this post


Link to post
Share on other sites

slid it up, i promise you it will make a difference

Share this post


Link to post
Share on other sites
Guest LuxurySlider

That thing has no room to move whatsoever the

Piping will just perfectly fit under the headlights.

Share this post


Link to post
Share on other sites
Guest LuxurySlider

I decided i wanted to paint the bay so it was now or never while the motor

was out getting new seals.

Here it is after about 2 gallons of super clean and a few hours of scrubbing.

7106760477_21aef337c1.jpg

IMAG0464 by msw1991, on Flickr

6960694482_5a3d677833.jpg

IMAG0466 by msw1991, on Flickr

And after the couple hours of scotch briting.

6960696716_ea6994e747.jpg

IMAG0467 by msw1991, on Flickr

Final Product (its more of the cream color in person NOT WHITE!!)

6960656956_67524558fa.jpg

imagejpeg_2_9 by msw1991, on Flickr

Front Mount!!!!

6960721172_050d09c1c6.jpg

578374_10150815440431181_696381180_12262832_876060707_n.jpeg by msw1991, on Flickr

Share this post


Link to post
Share on other sites

why not just leave it its factory color it looked good all cleaned up

Share this post


Link to post
Share on other sites
Guest DuaxMachine

Because white looks so much worse when it gets dirty, that you are forced to clean it, or it will look like the typical 240 engine bay.

Share this post


Link to post
Share on other sites

yea i dont get the whole painting the bay thing any car ive ever put a motor in with the exception of maybe 2 i just clean the bay and it usually looks great

Share this post


Link to post
Share on other sites

Joe, be real. Sure it works, but that bumper has to be a huge obstruction to that thing. I had mine on the x8 like that when I first got it running, then flipped it so the majority was right behind the grill high mount style. After beating the car, then feeling the thing with my hand, it was considerably less heat soaked.

Share this post


Link to post
Share on other sites

i also run 3" pipes and i have never felt it get hot. Ill check it next time im beating on her tho. But think about it if the case was the bumper blocking the air the damn radiator wouldnt get any either in the whole midsection. The air flows around that shit

Share this post


Link to post
Share on other sites

The radiator is much larger in comparison. But that's besides the point. I understand that air flows around that. But I also understand from first hand experience that putting it in direct airflow made a huge difference to the touch. This was during a summer of nothing less than 107* days.

 

Feeling how warm it gets after you beat on it will do nothing for you unless you can compare it to how it is in a different location, so don't waste your time.

Share this post


Link to post
Share on other sites

I suppose that's true. But all I'm saying is I have no issues. But how would I know. Maybe ill run without a bumper for a little while and see if I notice a difference.

Share this post


Link to post
Share on other sites

Its still obviously doing its job, but I think the bumper in front of it is negligable. 60mph winds are going to find their way in. But I would love to be proven wrong

Share this post


Link to post
Share on other sites

Log iat's with your emanage. Hell, you could prob tap the iat signal wire with something from the zeitronix and log that way if your Emanage doesnt

Share this post


Link to post
Share on other sites

If I remember right, the higher the heat, the lower the voltage is. Double check that though.

Share this post


Link to post
Share on other sites
Guest I<3BlondeGirls

your cream came out better than mines.

 

But then again you seem to have a lot more space to work than I did.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×