Jump to content
JZXProject
Kyle

EFI - Emanage Ultimate Thread

Recommended Posts

I'm learning as I go along, and will post shit as I figure stuff out. Others who know shit, please add to it.

 

EDIT: all problems I speak of about USB driver stuff turns out to be because I was using a computer with a 64bit OS system. To use the emu you must have a 32 bit OS. The software seems to work fine on win7, but there are little finicky things like when clicking on the car icon a window pols up saying language not found or some bs. Ignore it and it will continue. I'd still do xp if you have the choice as that's what the software was written for

 

 

Jumper settings: Turns out they're the same for vvti and non-vvti, here:

 

jp1: open -----------------------------------------------------jp11: open

 

jp2: open -----------------------------------------------------jp12: open

 

jp3: open ----------------------------------------------------jp13: open

 

jp4: open ----------------------------------------------------jp14: open

 

jp5: open -----------------------------------------------------jp15: 1-2

 

jp6: open ----------------------------------------------------jp16: open

 

jp7: 1-2 -----------------------------------------------------jp17: 1-2

 

jp8: 2-3 -----------------------------------------------------jp18: open

 

jp9: open ------------------------------------------------------jp19: 1-2

 

jp10: 1-2 ------------------------------------------------------jp20: 1-2

 

This jumper setting is for the full add/subtract fuel/timing control, so make sure you wire it up accordingly. You can find the diagrams in the link below to the installation and operation pdf

 

http://www.greddy.co...ate_Install.pdf

 

http://www.greddy.co...tion-manual.pdf

 

Also, I had to get a laptop that had xp. The software loaded on windows 7, but it wouldnt recognize the usb driver and wouldnt connect. I had zero problems with xp

Share this post


Link to post
Share on other sites
Guest Gaijin Smash Wayhoff

I had the same usb driver issue on mine (windows 7) with AEM software. Eventually got it to recognize, don't remember how. Something about the order of connecting it to the computer and ecu and loading the software..

Share this post


Link to post
Share on other sites

wanted to update this, there are different versions of the emu. The latest one is E. To find out what version you have, simply undo the 2 phillips screws on the back of the unit, then undo the 4 allens on the plug side, and carefully slide the circuit board out of the casing. My finger points to where the version stamp is located

d49274dd.jpg

 

So far I've figured out that if you have version "C", that you will need greddy injector adapter #2. This will prevent an extremely rich condition in 6 cyl engines. Said part seems to cost around $30 shipped. Part number is

15901504

 

My box that I've been running is version "D". I did not need the injector adapter with that version. Between the "C" and "D", you can tell the difference on the board as the jumpers are in different places, and there are also 6 extra resistors on the board next to the inj jumpers on version "D"

Share this post


Link to post
Share on other sites

how did you go mate?

I am getting an emanage ultimate for my 1j mx83 with auto(will go manual eventually)

 

where did you get a base map from?

 

Thanks

Share this post


Link to post
Share on other sites

From your stock ecu. You work from there. I highly suggest you have the wideband hooked up to the emanage. Makes it so you can use the autotune function and also datalog so you can pull fuel as needed and know exactly how close you're getting. There is an injector correction feature but you'll have to be spot on with the lag times from what I've seen.

Share this post


Link to post
Share on other sites

Alright guys, will be doing some more playing around with this crap soon. Just found this download recently that seems to support windows 7. New version 2.30, also seems to support the V-manage

 

http://www.trust-power.com/overseas/topics.html?id=4

 

Also, greddy has refined the emanage and released a newer, slimmer model that will be using different software as well. I've loved how easy it is for the average idiot (me) to use this stuff, so check it out. Looking at you Demesio.

Share this post


Link to post
Share on other sites

sweet! thanks kyle, i just got a new laptop with windows 7 :D

 

right now im waiting for my gte ignitor to start my harness, awesomeness coming soon :D

maybe do the write up for this e-manage thing... although it comes with stupid simple instructions

Share this post


Link to post
Share on other sites

Please tell me you didn't pay more than $10 for an igniter since they're on millions of cars at the junkyard. Also, yeah, the instructions are straightforward and on greddy.com under support and if you can't follow them you don't need to be doing it.

 

On windows 7 you might have a hard time connecting to the unit. Might have to uninstall and reinstall the driver for the USB on there. I'm having that problem now since my computer with xp and all my emu shit crashed. I should have it nailed down tonight and will post up what I did if/when I get it. Seriously thinking about getting a netbook today just for this crap

Share this post


Link to post
Share on other sites

Inland Empire junkyards can suck my penis, not one damn 2MZFE in sight for the last couple of weeks, so i bought it off canadian brian...

 

i had a notebook lined up for it, you'll want to kill yourself with that crappy processor and RAM... dont bother with that unless its freeeeeeeeeeeeeeee

Share this post


Link to post
Share on other sites

what wide band do we reccomend for the emanage??

I don't believe my current setup is running an o2 sensor from what I have seen on my exhaust... its still running stock management so dunno how that works..

Share this post


Link to post
Share on other sites

use an Innovate MTX-L, good wideband for the money, and it comes with the software to change the voltage output slope.

 

Not sure if you can make your own AF sensor voltage slope on the emanage...

Share this post


Link to post
Share on other sites

I'm running a zeitronix. You can set the range of the sensor in the setup menu. It's the little car icon with the hood popped, and under the "front panel" tab. it has a list of auto configured ones. Also lists other where like I said, you can set the range. IIRC I set mine at 9.6 and 19.6 for the Zeitronix.

Share this post


Link to post
Share on other sites

zeitronix thats the one driftmotion sells isnt it. which bits do I need from the kits they list?

I have an profec E01 that I will set up with the emanage so can display lots of crap on that too which is a bonus:) I think it displays AFRs ??

Share this post


Link to post
Share on other sites

http://tunertools.com/articles/FordMuscle.pdf

 

Read this article.

 

And then buy a Innovate MTX-L for around $200.

 

With the Innovate software you can set the voltage slope for the signal output to your ECU, so if your ECU has a fixed slope, you can adjust the Innovate to match it.

 

The best cheap wideband I have ever used.

Share this post


Link to post
Share on other sites

That is cool shit for a cool price

Share this post


Link to post
Share on other sites

But that article must be biased. The aem sucks compared to my zeitronix from what I've seen. I didn't buy my z, it came with the car and had almost all the bells and whistles. Pressure sensor is a neat option, the all in one gauge is cool. But being able to set your own voltage slope like Jimmy is talking about will prob be nice for your tuner.

Share this post


Link to post
Share on other sites

AEM is fucking garbage compared to a Zietronix.

 

That article is pretty old too, I'm sure Ziet has made their shit better since then. Innovate shit just keeps getting better and better though, and for the price it's just unbeatable.

Share this post


Link to post
Share on other sites

Okay, So I figured out that this bs software works on win7, but THE DRIVER FOR THE USB CONNECTION ONLY WORKS ON THE 32BIT VERSION.

 

Since I'm no computer nerd, I bought a notebook with 64bit win7. It seems to work okay though when you click stuff it says the language is not found, click ok, then proceed. I had used a buddy's netbook the other day that he bought just for his gti software for his 1.8t. it's 32bit, so I was able to pull fuel so I wasn't running 440s on the stock ecu map. I did it by using the global injector correction which isn't really ideal and will need alterations in individual cells on the I/J map to be correct. Also, setting the lag time of the 440s didn't seem to work as well as it did on my old notebook with winXP. This could be a problem with the win7 running the software, as I've read that people have emailed greddy about this and they say xp or older only or some shit. I dont know that first hand, though I do know I never got the language error on XP, but also I was on an older version of the software at the time as well. 2.20 to be exact

 

So basically, any of you that are playing around with one of these, feel free to add into this as you find stuff. I will hopefully be figuring some of this stuff out this week. Have the boys bday party this weekend, but should pull an all nighter to get the engine in the car and will need my emu for sure, so this has to be done. My plan of attack is to delete win7 64bit and go to win7 32bit, or possibly xp. I only wanted this notebook to play with my emanage and to call some of you fags anyway, new or old OS matters not to me.

Share this post


Link to post
Share on other sites

Well I got my emanage ultimate and it has the loom and a manual ecu from a jzx90 but my car loom and ecu is jza70 and auto so what are my best options?

Find a new jzx90 or jzz30 auto Ecu and patch my loom over. Get a jzx90 or jzz30 loom?

 

Or other lol

 

Cheers guys

Share this post


Link to post
Share on other sites

Are you good with wiring? Get pinouts of both a70 and x90, get x90 plugs from what yall call the wreckers, then one by one clip and solder til you have an x90 harness. Or to make it real easy, label each wire with its function with tape a ways down before you go depinning/clipping that way you can't fuck it up and it'll still be there after you solder/heatshrink for double checking purposes

Share this post


Link to post
Share on other sites

Yeah I think thats gonna be the best way.

I have some mates that have played with wiring ecu's before so should be ok:)

So I will need a new x90 auto ecu to replace the manual x90 ecu so my auto will work...

Wish I could afford a manual conversion at the moment:(

Share this post


Link to post
Share on other sites

I'm sure trading straight up with someone will be no problem

Share this post


Link to post
Share on other sites

I am so glad you started this thread. you have just motivated me to start play with mine again. So a quick run down of my setup. I have a 1.5j with the hks t3g kit using s14 bb turbos. I am running a jdm 6mt jza80 with stock 440 injectors. The problem i have it running really rich at wide open throttle. I can't figure out how to get that damn auto tune to work. I do have aem wb hook to the ecu and a/f target map filled out. It was running rich like this when i was using jzx90 ecu and 370 injectors. I am goin to check that version of the board tonite.

Share this post


Link to post
Share on other sites

×