Jump to content
Sign in to follow this  
Guest zOmBiEsTyLe

1JZ in limp mode?

Recommended Posts

Guest zOmBiEsTyLe

so after getting the powersteering to work again i seemed to have run into another snag... after having rebuilt the front end of my car and getting everything to run right, it was time to go for a shakedown run, so i took it out for a rip and at first there were no engine light, then as soon as i hit 2500rpm the engine light comes on and i hit the boost limiter, so i drive back to my shop and pin E1 to TE1 in the Diagnostic port to get the code, and its giving me code 13. and i checked the turbos so both are in good condition and still make boost

 

so after searching online i finally find the codes.

 

6 or 12

RPM SIGNAL-NO SIGNAL TO ECU FROM DISTRIBUTOR ("Ne" OR "G") AFTER ENGINE HAS BEEN CRANKED

DISTRIBUTOR/CIRCUIT

STARTERSIGNAL CIRCUIT

IGNITER/IGNITER CIRCUIT

...ECU

 

13

SAME AS ABOVE BUT AFTER ENGINE HAS RUN AT 1,000-1,500 RPM

DISTRIBUTOR/DISTRIBUTOR CIRCUIT

ECU

 

 

so technically i have code 12 but because i can rev past 1500 rpm its telling me code 13, so first things first RPM sensor, pull the plug from next to the timing belt tensioner and the crank sensor is 1275 ohms hot and 758 ohms cold, all within spec

 

next we checked all the coilpacks and ignitor and all of them are still good, no cracks, nothing is loose.

 

and since i dont have a hoist i couldnt really get to the starter, we even pulled the plug on the injectors and just held the key and the engine will turn over and over and over strongly without any signs that the starter is about to lose power or die so i figured the starter is all good :lol:

 

we even tried to reset the ECU by draining it of power completely and plugging it back in, and the same code 13 still comes back,

 

So that leaves ECU... and that stumps the hell out of me, dont get me wrong i know how it works and i can build a computer from ground up, i even chipped my own Wii and Xbox 360 but it pretty much stops there, but for some reason when it comes to car ECU i just freeze and everything escapes me, but as i did research, it seems that the capacitors inside the ECU can somehow just up and kick the bucket and start leaking. so it looks like i will have to open up the ECU and check the capacitors.

 

so my question is, what signs do i have to look for in the ECU to know that its kaput or is there anyone that has had this problem and figured out what to do.

 

any help is greatly appreciated.

thanks

Share this post


Link to post
Share on other sites

weird smell and discoloration on the board around a capacitor.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×