Jump to content
Sign in to follow this  
rayray

quick update

Recommended Posts

some of you may have seen aaron post some of the current pics of my car on toyotacressida.net, here's just the same link. linky there's a bideo there too

Share this post


Link to post
Share on other sites

I like the fmic routing. I have the same core and was considering going through where the ABS unit sits. Did you just make all new brake lines? How did you split the 2 fronts? Just a "T" maybe?

 

Man that's awesome.

Share this post


Link to post
Share on other sites

well i never had abs so i don't even know what the units look like or where they sit :?

Share this post


Link to post
Share on other sites

right now it's sitting in aaron's garage so i need to pick it up friday night and hide it in the garage until it gets smogged over the next week or so

Share this post


Link to post
Share on other sites
well i never had abs
me either, i should go to the gym and work out or something.

Share this post


Link to post
Share on other sites
right now it's sitting in aaron's garage so i need to pick it up friday night and hide it in the garage until it gets smogged over the next week or so

 

good luck withh that mate! let us know how that goes.

Share this post


Link to post
Share on other sites
I like the fmic routing. I have the same core and was considering going through where the ABS unit sits. Did you just make all new brake lines? How did you split the 2 fronts? Just a "T" maybe?

 

Man that's awesome.

 

dude that sucks, just find a donor carin a junk yard, get non-abs brake lines and rip that shit outta there, ABS on these cars sucks MAJOR BALLS. MAJOR. Then you can run the FMIC piping through giant speed holes in your hood like everyone else does. yeah.

 

EDIT: hey Ray, is this yours?

DSCF2498.jpg

Share this post


Link to post
Share on other sites

took the car out for a spin friday and sat. all i can say is the 1JZ = :twisted: the pedals came out nicely despite being MA70 pedals to begin withh. there's still some tiny issues, but all major kinks seem to be worked out.

 

i'm still getting vibration issues withh the wheels at speed and my check engine light comes on somewhere past 50-60mph so i need to check those.

 

brian, do you get a lot of air rushing up the shifter opening? cus right now i'm not running a shift boot and i'm thinking if i run a cloth boot, it's going to balloon up at speeds above 40 mph or so. i get a lot of air (but luckily not much debris and water) coming up through there... did u block it off or something? a rubber shift boot (if i find one) would probably work fine though

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×