Jump to content
Sign in to follow this  
bigtoepfer

DM P/S Hose: Leak

Recommended Posts

So we did the 1J swap this weekend and now I can't for the life of me get the damn power steering to quit leaking. Every time we think its fixed it pisses out all the fluid within like 30 mins max. Its coming out of the coupler between the DM High pressure hose and the steering rack. Anyone else have this problem and how did you solve it?

 

I tried changing the copper crush washer and that didn't help. Tried taking the crush washer out and that helped for a bit then not anymore. Anyone?

Share this post


Link to post
Share on other sites

.... you either stripped the threads on the hose by over tightening it... or your racks stripped or broke. try using some plumbing tape and nig rig that shit up. High pressure fittings are gay

Share this post


Link to post
Share on other sites

i had the same problem on mine.i had to buy a new slightly thicker copper washer fron Pep-Boys and use high pressure silicon around the washer.make sure the washers is centered when you bolt it back on and let the silicon cure fully.its a bad design they used where the OD of the threads is just a tiny bit smaller the the ID of the washer ,should have been tappered IMO

Share this post


Link to post
Share on other sites

I'm using their stuff, hasn't started leaking yet. If it does, crush washer and teflon tape?

Share this post


Link to post
Share on other sites

well today we put on a nylon washer. Threaded it onto the coupler then put the coupler on. Poof problem solved.

Share this post


Link to post
Share on other sites

I'm pretty sure I replaced the copper crush washer that came with mine with a thicker and bigger dia. one.

 

I wouldn't trust the nylon to last all that long. I'd keep an eye on it.

Share this post


Link to post
Share on other sites

Had that problem with mine the washer they supply is shit so i used thread sealant and a new bettter fitting washer

Share this post


Link to post
Share on other sites

mines been on my 2j and 1j, no problem, and i got mine back when they only had mk3 ones. just went and got better washers, and when i worked there, i had zero problems with the washers they had, the only washers that sucked dick were the ones that came they used 3 years ago.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×