Jump to content

Recommended Posts

Awesome super mega thanks to feisar who supplied me with a cluster, harness and now a dimmer.

 

Everything in the cluster not digital lights up. Dimmer makes the odometer backlight brighter and dimmer and I get warning lights in the bottom. Pushed all the buttons and turned all the knobs: nothing from the gauges themselves.

 

I have checked all fuses unless the digi dash requires extras that aren't on the usdm fuse panel cover diagram. The dimmer, mirror, upper radio controls, black boxes and cluster are plugged in. Fuel level sender was replaced with brand new digital unit. We are sure the wiring is correct.

 

Any help appreciated, new Canada guy w/ 1j and digi cluster or feisar :)

Share this post


Link to post
Share on other sites

im trying to eliminate simple things first. is there anything that NEEDS to be plugged in and functioning for the digi portion of the cluster to light up?

 

i.e. switches, boxes, connectors to ECU?

Share this post


Link to post
Share on other sites

pps, working to get the car started and driving tomorrow afternoon so gauges would be a plus :)

Share this post


Link to post
Share on other sites

hmm. check that the power related wires have power in them? maybe a change at a harness plug might not be connected?

 

i know the dash worked when I pulled it from the car.

 

if i think of anything i'll post it.

Share this post


Link to post
Share on other sites

we used the usdm diagram, discovered that most of the wires in the opposite side of the connectors on each harness serve the same function and are even hte same color.

 

wouldnt hurt to have the canadian one too but i havent seen it online... aphxero said he had one but then he sold his car and forgot about posting it.

Share this post


Link to post
Share on other sites

If anyone else is interested I will confirm what is needed when I figure it out.

Share this post


Link to post
Share on other sites

bump. holding me up big time, i'd rather find out from someone with knowledge if i left something out than tear the whole thing apart or start buying replacement parts.

 

i believe feisar when he said that the cluster lit when he pulled it so that leaves something not being plugged in right for it to work or maybe wiring.

Share this post


Link to post
Share on other sites

hey man just got your pm sorry.

 

all the lights on the cluster that arent the digi stuff should power themselves. the digi portion needs an ignition source. im guessing your tach, speedo, temp and fuel dont light up but what about the PRND2L? i dont thin it should unless the rest of it worked .

 

if you check the diagram for the car the digi cluster came out of. note the pin position of the ign source as it should have to be moved or possibly added into your factory conector

 

and if you want you trip meter to work make sure a B+ wire goes to that or it resets everytime the car is shut off

 

hope this helps. ill try to find my wiring stuff and remember what i did exactly. and if you got the msd tach adapter dont hardwire it just yet... mine took some finess to make it work.. the instructions have 4 or 5 ways of putting it in and the one that seems most likely was wrong haha. (2jz)

Share this post


Link to post
Share on other sites

Hey thanks for looking. Yeah I get nothing from the digi portion. But I'll reheck the harness this weekend. Haven't started the tach adaptor yet, thanks for catching me on that.

Share this post


Link to post
Share on other sites

it looks like hammered shit you dont want one trust me. only fags get them for their cars and im a fag.

Share this post


Link to post
Share on other sites
what does this cluster look like? where can i get one?!

easy, go pull one from a junkyard in canada

Share this post


Link to post
Share on other sites

You kidding me is that the famous digi dash off a canadian cress? If so that shit is tight , looks like a f1 fighter panel.

I bet that circular gauge on the right is for homing in on enemies. lol.

Chrisol sell me one!

Share this post


Link to post
Share on other sites
it looks like hammered shit you dont want one trust me. only fags get them for their cars and im a fag.

 

thats cool. i do better with pics. hammered shit or not i want to see it, and i dont really care to know your sexual orientation.

Share this post


Link to post
Share on other sites

i think bill had the pics of his, it had a bhg icon too if i remember. toyota really thought it through on this one

Share this post


Link to post
Share on other sites

canadians get all the good stuuf.

denim tux

digi dash

factory 6 speed

and free health insurance.

you fuckers are lucky. eh!

Share this post


Link to post
Share on other sites

you forgot the headlight blasters, LSD, unmotorized seatbelts and hot vaseline dispensers to keep our skin amazing.

 

we also get really shitty weather and pay fucking monster taxes to a gov't that can barely spell words over 5 letters.

 

sucks that the dash is being a pain to wire. i thought having the whole dash harness would get you somewhere fast. wish i could help more but there's little i can do to figure it out.

Share this post


Link to post
Share on other sites

negative, but i have been getting my daily back on the road the past week. hopefully i will get some time to devote to it this week/weekend...

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×