Jump to content
Sign in to follow this  
EightyOne

Building up the cresta

Recommended Posts

its been a year, still the car not yet found the road..hope to get on the road by sept..

upgrade from w58 to r154 together with OS Giken supersingle..

and also got myself a JIC Magic front coilovers..

GetAttachmentaspx1.jpg

Picture017.jpg

Share this post


Link to post
Share on other sites

nice and tastefull keep the viennas and use massive flares ! :D

Share this post


Link to post
Share on other sites

sorry been lack of update..car now in my own porch,

finish transplant the 2j,had abit of problems, i had the car revving rapidly when i'm on 4th n 5th gear at 5k+ rpm,

might be clutch slip, or anything else..still doin troubleshooting..

 

Share this post


Link to post
Share on other sites

Yup that is your clutch slipping just change that out and I'm sure you will be set

Share this post


Link to post
Share on other sites

replaced the suspension as the stock one kinda bumpy..

also replaced the brake lines to braided as the old lines is in need of replacement..this is my previous line intended to be use on my previous 180sx..

mind the brakes,as lack of green to get a nissan 4pot..also used s13 link arm stabilizers

 

02042011930.jpg

 

also replace is the servo brake pump..bleed the system and can see the shit out of it..

02042011933.jpg

 

02042011939.jpg

 

install the viennas..

specs are 19x9.5+18 fronts and 19x10.5+5 rears..

front with max negative camber plates doin fine, rears out by few inches..

 

02042011936222.jpg

 

02042011934.jpg

Share this post


Link to post
Share on other sites

yeah thats what i thought.. i lost the slave pump shaft and replace that shaft without knowing the correct lenght..cud it be related?

 

fyi, i'm using a used OS supersingle, buy it from a fren which was ok on his gearbox..

 

also the speed sensor is not connected yet..

Share this post


Link to post
Share on other sites

yeah it can be your engagement from your pedal as well it just needs to be adjusted thats what we had to do to one of our cars

Share this post


Link to post
Share on other sites

well, the car is not entirely finish,need a lil tweak but its drivable..

 

exhaust now only dwnpipe..wil do the pipework when time available..also looking up tidying the engines wirings..messy!

 

IMG_6710.jpg

Share this post


Link to post
Share on other sites

add a tad bit of camber front and back and your car will be sitting pretty

Share this post


Link to post
Share on other sites

not much update but some problem with the car at the moment

 

last time,bought a used clutch(osgiken supersingle push type conversion on the r154) off from a fren and the clutch was working fine before he took it off..

 

refering from the video, is the clutch slipping in ur opinion OR izit the speed sensor connection which not connected yet?

 

was really hopeful that the speed connection is causing the problems and not the clutch..damnn..

Share this post


Link to post
Share on other sites

That's the clutch man

Share this post


Link to post
Share on other sites

sad to hear that.. :(

hav to fork out $$$ kacheng!!

car will hav more ground time for now..

 

strip out the interior..

doin some cleaning & wiring to make the cluster working..

too bad theres a slight difference between the car with the wiring guide by the jzxp..

08042011965.jpg

 

or else will go this route..custom clusters..

KGrHqJi4E1MFUEk0MBN2iMzpBQ0_12.jpg

Share this post


Link to post
Share on other sites

fixed the clutch problems..replace my faulty slave pump,then turns out to be the shaft pushing the clutch fork is slightly longer to make the clutch engage when it shudnt be engage..adjusted and now runs beauty..

 

28022011772-1.jpg

 

30042011040.jpg

 

30042011041.jpg

Share this post


Link to post
Share on other sites

Work equips are wayyyyy better. I have massive problems out of my clutch slave cylinder as well. I have to rebleed every few days

Share this post


Link to post
Share on other sites

o shit bro. just try not to peg that thing at 88mph or the flux capacitor will kick in yo.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×