Jump to content
WhoreMouth_Jr

Team Somehow Running Again x7

Recommended Posts

Shakey hands and a dozen open vac ports.

 

Hollah at me if you need the dude for immo bypass.

 

Share this post


Link to post
Share on other sites

^ welcome to the 1uz vvti club. If you go 5 speed, the Russian sell a transmission emulator that definitely made a difference in my 3uz swap

Share this post


Link to post
Share on other sites

haha thanks, I already got 1 on order with his tach adapter that I hope also works.

What did you do for a tach?

Share this post


Link to post
Share on other sites

No solution yet. I did try to source the lead from the ecu but it didn't work. The tach needle just jumped randomly. I'l get the tach adapter from the Russian. I swapped a 3uz into a 90 supra running 1uz vvti harness and ecu.

Share this post


Link to post
Share on other sites

Win't a tach adapter from someone like Accel, or MSD work ?

Share this post


Link to post
Share on other sites

I made my tach adapters from old cooling fan relays... not saying it'll work for your setup... just saying Google

Share this post


Link to post
Share on other sites

Made my first one from a cheap 110vac to 6vdc wall transformer.

But it only lasted about 6 months......

So I stopped being a cheap ass, and bought a couple of Accel units.

One wired in the system, and one in the glove box in case the first one dies, because on my system, if it fails, engine no runny......

Share this post


Link to post
Share on other sites

Jokes on you demesio I already Used Russia guy. He's the one who bypassed our immobo ECU.
I sent it out and had it back in like 10 days (2-3 of those days it sat in russian customs).

 

I was planning on using the msd box with his adapter box. I think you still need to convert 8cyl (which is actually just 4x2) signal to 6cyl right? Pretty sure he said he can also install the pullup within his adapter box so...

 

There is roughly -10% chance the vvti UZ will ever be on a stand alone. I'm pretty sure 280+ will be enough for the x7.

Plus it's got that ACIS shit and itty bitty rods

Share this post


Link to post
Share on other sites

Itty bitty con rod:

 

625x465_10474491_7073735_1459342910.jpg

 

7M connecting rod:

 

wartsila_4_stroke_con_rod.jpg

 

Girls will tell guys with the itty bitty rods, that it really doesn't matter.......

Share this post


Link to post
Share on other sites

Hoping to take this thing for a drive this weekend exhaustless..

 

Probably gonna try and start assembling that 2jz thingy too. maybe

Share this post


Link to post
Share on other sites

Haha! It does sound amazing. We went to finish up all the little stuff so we could drive it today.

While filling the coolant we hear it pouring out from somewhere. Turns out last guy didn't do that good of a seal job on the thermostat housing (The gap at the top right was where the coolant was pouring out of).

 

Also got the tach adapter and Auto trans simulator. Tach adapter works (still need msd box shit)

Also made one of those relay boxes for the fans that I made for the white car for this car.

Josh got the little radiator probe all wired up (along with a bunch of other stuff today), everything looks pretty good.

 

Also touched the white thing again. Got the timing gear tach'd, a billet tensioner bracket some 1000cc ID's and a Radium 1jz Rail (hopefully the last $$$ I have to spend until tuning then forever (besides tires)).

Just gotta put the head and head related shit on.

 

6PLyGIt.jpg

 

a8ANBcm.jpg

 

EPdmLcJ.jpg

 

l9Fxl5d.jpg

 

p8DRxUt.jpg

 

sFA3F1H.jpg

Sad dog is sad

Share this post


Link to post
Share on other sites

dude, undo all that bullshit electrical tape and grab some braided mesh from pico, the loom style that wraps around if youre laxzy like me and want the wires serviceable if you damage them or need to change something.

seriously, takes way less time and effort and looks a million times better, let alone all the glue bullshit if u ever have to service it after it all falls off.

Share this post


Link to post
Share on other sites

Can't be bothered haha I used the mesh on the white car though ;)

 

Edit*

Seriously this car its ghetto, getting it running so we can crash/sell it

 

(ref for the relays I did for MY car)

http://jzxproject.com/bbs/index.php?showtopic=3461&p=173427

Share this post


Link to post
Share on other sites

I use harness tape from Japan.

It doesn't bleed gooey glue until it falls off like plain jane household electrical tape.

 

And then there is the convoluted wire conduit, that isn't split, just like HKS uses.

It doesn't spring open at every bend, and expose the wires.

Bit of work though, as you must pull your wires through it.

Share this post


Link to post
Share on other sites

Drove this shit box:

 

It was slow, it was loud.

Also turns out when we modified the header we didn't take into account the correct engine angle and it doesn't quite clear the rack. So fuck this car

 

Also traded my china man rail and FID (Fuel Injector Development) injectors for ID's and one of those new radium rails.

10/10 would recommend to anyone.

 

Rerx4tW.jpg

 

kFN6FRi.jpg

 

l601mnH.jpg

 

Q5DhAyX.jpg

 

G3OItTc.jpg

 

Only downfall is that the require the oem hardware(which I didn't have anymore) and the oem spacers (which I barely found)

Other than that solid!! Even comes with different feet if you are running taller injectors

 

Have this shitty pano I took with my phone when I was back home in october

tHhYihQ.jpg

Share this post


Link to post
Share on other sites

I'm only running 850cc and already running a afpr so I thought it might not be unnecessary.

 

But I can be convinced other wise, you know me ;)

 

7LVCg4W.jpg

 

I'm a little sad the PHR pulleys look to be fading?

Share this post


Link to post
Share on other sites

havent u ever seen old tial wastegates? they all fade really horribly. best to get silver or something. i "heard" it was due to it being on aluminum vs steel and how it retains its colour. like why the HKS pulleys there are still colour bright.

Share this post


Link to post
Share on other sites

In a surprise turn of events my car should start today. Would have yesterday but you know nothing is open on christmas.

 

The dude I wanted to tune my car is in town and there is a small possibility that he can tune my car tomorrow so I jammed yesterday and saturday to get it ready to go.

Just need fluids and misc. stuff from the hardware store

 

xfX8A53.jpg

 

XDrBazv.jpg

 

 

 

 

In other news, lover boy wiped of this slick exhaust for the v8 car (not the finished product), now we no longer get vapors in the cabin while driving it, and it actually has some low end.

Still working out some small kinks hoping to take it to the next open drift in Jan.

 

zyEeeCu.jpg

Share this post


Link to post
Share on other sites

Well the stars aligned and everything went right (almost)

I was able to get everything in and going. I was able to get in contact with the tuner I originally wanted to use (Thanks Jose <3 ) the first time. Not to mention he was in town on vacation!

We were able to find a dyno rental, literally the only one in ~50 miles that was open and not booked all day. He worked his voodoo real quick we only were on the dyno for like 2.5 hours. I only had 1 coolant leak and one of the cam gears slipped because when I reset it I didn't tighten it all the way (ya I'm dumb) Honestly I was expecting everything to go wrong but nothing really did.

He got it running pretty solid at 11.5 psi and also went up to 13 for SnG.

 

He pretty much confirmed that the place I got it tuned before fucked it pretty good, the few people I showed the map to said the VE table was trash, and when he went into to set up the knock sensors they other shop had it set to only read off of the front one, and it wasn't even configured properly so it would have never read anyways (fuck me right?)

 

I seriously can't thank this guy enough for going out of his way to help me out on his vacation. Feel free to look him up if you are going AEM (as he works for them) his name is Beau Brown, but I'm pretty sure he's at least taking a break from tuning in his free time.

 

c6006Ey.jpg

 

3AYWh6I.jpg

(It's a dynapack so remember to divide the HP by 2 right? ;) )

 

S198PJF.jpg

Must be a 7m on there with all that tq <3 Gordo (maxed 4th gear input on their machine and had to go to 5th hah)

 

 

 

Side story, after we were done at the dyno place we went to grab a bite to eat, and my dumb ass locked the keys in the car. The car has 1 Solex on the drivers (cause I'm too lazy to finish the other 2) and the passenger and trunk are the original key for the car. But the key for the ignition is from my old cressida. And the keys I took with me into the burger join were only the ignition/hood keys, FML. I feel like an idiot once again, call AAA let them know I'm locked out of my car (already used them that day to tow the car 40 miles to the dyno hah) text my girl that I locked my keys in the car, immediately after I hit send my phone dies, and I realized that throughout the day I had slowly moved all 3 of my fucking charger cables (USB-C) from the Prius to the cressida and now they were all locked in there. Gay story I know but it's just like everything that could have went wrong (except the car) did.

 

:wub: What a day :wub:

Share this post


Link to post
Share on other sites

I thought the big warning had to do with your rear stub axles........

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×