Jump to content
Sign in to follow this  
N.O. Drifter

stripping is fun...UPDATE with drift pics/vid, but still fail

Recommended Posts

hey whats up jeremy(i am right?). i went withh the 5m because i wanted to first learn about it, well the m series engine in general. My mech knows shitloads about the engine so i went withh one that if i had problems withh power or something i could get his help and advice. Also i went withh it b/c this was my first build, i din't want compicated wiring for me a noob, also, if somethign went out i can get engine parts real easily at a junkyard or my mech. I always plan on doing a ijz. but i kinda want to do it in a mx83. i have the 5speed swap, r154, and the 7mgte maf sensor here at my house, so i have stufff for it. i am slowly collecting parts. i also know a guy near me withh his old, still in goodshape 2jz twins. he has other parts too. i was thinking of getting the twins and manifold and trying to put them on the 1jz, but anyway i am slowly collectign parts and knowledge. I just got finished helping a friend do a sr swap into his 240, i helped him every step of the way including wiring. I am trying to take things slow before i get into a jz swap, which will require knowledge i don't have.

Share this post


Link to post
Share on other sites

yeah, it's jeremy... you have a pretty good memory. that sounds cool, I can understand where you're coming from. If you're going that route though, try to spend as little money as you can... you know what they say about polishing turds. As long as you're out there driving and having fun, thats what it's about.

 

i finally got mine running, need to get some bugs out but i'm hoping i'll be done in time for mineral wells in july.

Share this post


Link to post
Share on other sites

cool

 

yea i just picked up a corolla and will be getting a free 22r that i will drop into it. an maybe have a little fun this summer.

Share this post


Link to post
Share on other sites

LET THERE BE OIL

 

 

 

the oil problem is fixed, now i just have to tune the fuel and air.

Share this post


Link to post
Share on other sites

well i tuned the fuel and air pretty good today, it was jumping in the 14's the whole time. i revved it real high and it sounded so sweet, then i revved it to 5k rpms and i hadn't tunned the afc at that rpm, so when it hit, it went too rich and flooded itself and a big white puff of smoke came out, but when i let it rev low again it sounded nice. turbo spooling real nice and engine just revvign so smooth.

 

on tuesday i will try and tune it better and maybe drive it.

Share this post


Link to post
Share on other sites

well alot of bullshit had happened since last time. first my turbo oil seal started leaking so i sent it back to rabid chimp since it was under warranty. i got it back a couple of weeks ago and in my spare time i have been slowly putting it back together, i recently bolted up the ic and the oc. i need to redo the bottom ic pipe and the one that crosses over the engine to the TB and get some type of exhaust made up and i will be ready to drive it. and damn i was on the second page withh this thread.

 

newic2.jpg

newic1.jpg

Share this post


Link to post
Share on other sites

more fail from me

 

got it started......

http://s38.photobucket.com/albums/e114/cjo...urrent=vid2.flv

 

then i noticed some smoke.....

http://s38.photobucket.com/albums/e114/cjo...urrent=vid3.flv

 

 

 

 

 

then turned it off.....

turbooil1.jpg

turbooil2.jpg

turbooil5.jpg

 

and my turbo seal blew again. FUCK

Share this post


Link to post
Share on other sites

are you running a restrictor for the oil feed line? you may be over pressurizing the turbo.....causing the seal to blow.

Share this post


Link to post
Share on other sites

^hopefully this weekend i am going to hook up a mechanical oil press gauge right before the turbo to see what the pressure is to the turbo.

 

i talked to rabidchimp about it, we went over the return line and how the flange is bolted to the turbo. i am pissed b/c i got the turbo from him and it blew before and it was warrantied and now it did it again and i want to know why.

Share this post


Link to post
Share on other sites

What size is the feed line. . I wouldn't trust a company that hasn't actually sold or installed tons of turbos. .

 

It should be a -3, if its a -4 you need a restrictor. . AND if its Ball Bearing then you need a restrictor for both. . like a 1mm hole i think it was. Its not the PRESSURE blowing it man. . its the VOLUME at that pressure. .

 

NOW . . you need to adress your DRAIN situation. . It needs to be fuckin short and sweet. . Straight as fuck. . no bullshit copper 90's, no parts of it running uphill. . clock the turbo withh the drain facing STRAIGHT DOWN or fuckin . if its closer to clock it TOWARDS the motor to get a straighter shot at the block entry. then do so. . its only GRAVITY flowing OUT of the turbo so if you backing it up. . YOUR SEAL WILL EAT SHIT.!!

 

Goodluck withh the M. .

 

G.

Share this post


Link to post
Share on other sites

run a -3. thats what ill be using. check your oil pressure if its ok return the turbo for a refund then buy if from a reputal company......

Share this post


Link to post
Share on other sites

well i had a kink in my return line, couldn't see it untill i got under the car.

 

problem is i have no good turbo. so i did this...

 

 

 

HPIM0640-1.jpg

 

gasp, no turbo.

 

well i started it up...

 

 

and went for a drive. filled up the tank. drove a little farther and noticed i forgot to keep the hood down with a strap, so i turn around to go back home.

then the car killed at a stop, started it up and it wouldn't rev past 1300 at wot. got home and my shitty intake as seen in the pic came loose.

 

so does anybody have a spare 5m intake i can have. Please!

Share this post


Link to post
Share on other sites
Guest Push

lol, I love 5mges... I will look around and see if I still have my stock one laying around...

Share this post


Link to post
Share on other sites

last weekend it was like this.

 

 

then checked plugs and #2.....

 

badplug.jpg

 

 

now it runs like this

 

Share this post


Link to post
Share on other sites

a little update. car runs and i got a drift event feb 8 on the naval air station 5 minutes from my home.

 

here are a couple things i have done.

 

battery box

battbox.jpg

 

vacuum, temp, oil press guages

guages3.jpg

 

 

also at work i have started to create a bumper from scratch fiberglass at work

bumper1.jpg

Share this post


Link to post
Share on other sites

The bumper looks pimp! Paint some ghetto flames on it and your ready to rock lol

Share this post


Link to post
Share on other sites

^nah, i am going to trim it down and cut openings in it for airflow, but not until after sunday's event.

Share this post


Link to post
Share on other sites

looking good. about that plug, some one is either fucking with you by closing your gaps, or something hit the spark plug and slamed it closed. either way it runs thats awsome! sound kick ass to boot!

Share this post


Link to post
Share on other sites

^I think when i went to put it in, i either dropped into the hole and it hit the side or something, and i ended up screwing it in.

Share this post


Link to post
Share on other sites

well here's some pics of sunday's drift event and a short vid. also under drift event pics.

 

cressida5.jpg

cressida4.jpg

cressida6.jpg

cressida3.jpg

cressida.jpg

cressida2.jpg

 

th_nas-cressidadrift.jpg

Share this post


Link to post
Share on other sites

did some stuff lateley. finished 5 lug and subframe bushings

 

1251038639.jpg

 

 

took out sunroof

 

1251039063.jpg

 

1251038579.jpg

 

bitch was heavy so i had to take off door to get it out.

 

1251038498.jpg

 

put in fiberglass piece from work

 

1251038219.jpg

 

1251038407.jpg

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×