Jump to content
Lofty

Anyone have a solution to the PS fitting.

Recommended Posts

I'm pretty pissed at this powerhouse racing piece I got.

4657_1_.png

I got this fucking thing and it doesnt go in without crushing the o-ring. Tried a bigger one, tried a smaller one, tried one the same size.
Not sure what I am doing wrong but I've wasted a ton of PS fluid already. I just don't think it's a good product.

Does anyone have any feedback? Im about to weld an AN fitting on the stock piece...

Share this post


Link to post
Share on other sites

Im about to weld an AN fitting on the stock piece...

 

 

worked for me...

 

i'll say this because it's you... take the o ring off before you weld :P

Share this post


Link to post
Share on other sites

 

 

i'll say this because it's you... take the o ring off before you weld :P

 

laughing into my coffee...almost sprayed myself.

Share this post


Link to post
Share on other sites

I bought the same fitting. Drops in just fine, but I haven't hooked up my power steering yet so I can't comment on how well it works.

Share this post


Link to post
Share on other sites

Jacob, I have all stainless lines and a custom res. I don't need the peacock fitting but I need something that's -10 as I built this setup for that size.... -_-

Fuck you Demesio.

Boris -- It drops in well but manages to somehow leak. I don't get it. Maybe I'm doing something wrong.

Share this post


Link to post
Share on other sites

If it drops in, you have the wrong o-ring, or it's a cheap pos from china, and the o-ring grove is way out of tolerance.

Call the people you bought it from, get the required o-ring size, not one smaller, not one larger, the correct one.

 

Then check the bore where the fitting fits into, are there sharp edges that cut the o-ring ?

And most of all, lube the o-ring before installing the fitting.

They don't like dry insertions, even if your girlfriend does.....

Share this post


Link to post
Share on other sites

couch cushions should always be dry, or at least start out that way.

Share this post


Link to post
Share on other sites

It seems like I push down straight with it and I can feel the oring "Pop" if that makes sense.

I got the o-ring size from them... else I will be sending it back.

Share this post


Link to post
Share on other sites

thread closed for too much innuendo

 

I haven't had one 'pop' for 45 years......

 

12mm ID, or OD?

 

I just searched eBay for 12mm x 2mm o-ring, and came up with both in under 10 seconds, including typing the search.

You need Buna-N material.

Share this post


Link to post
Share on other sites

Put a random o-ring on it. Found out the pump seal was shitted. Took my 1JZ pump and bolted er up with one of those brown o-rings.

Lmao. Works now.

Share this post


Link to post
Share on other sites

I just bought this and don't have a leaking problem. FWIW, I am using an IS300 PS pump instead of my Aristo pump. Glad you got it sorted

Share this post


Link to post
Share on other sites

×