Jump to content
Sign in to follow this  
AcidTrip

TAIL LIGHTS DON'T WORK

Recommended Posts

1990 Cressida

 

*Recently swapped my taillights, reverse lights, blinkers, brakes, license plate, and dash lights to LEDS and they worked fine for a couple weeks*

 

Now having these issue's:

 

-head lights wont turn off.

-taillights don't work.

-dash lights don't work unless i brake.

-license plate lights don't work unless i brake.

 

-brake lights do work

-reverse lights work

-blinkers work

 

So my logic was my led's are my issue. replaced all the led's with normal bulbs. Issue still persists.

 

also noticed i had some damage in my drivers side fender harness. i repaired it and issues still persist.

 

i also checked the fuses and they look fine and checked my tail light ground and it looks fine.

 

Any insight? as to how i can un-fuck myself.

 

 

 

Share this post


Link to post
Share on other sites

Nope, your fucked......

 

By the way, when YOU figure it out (if you do), post something then.

Share this post


Link to post
Share on other sites

Get the ewd and confirm circuits. That's an idea. Matter of fact, it's THE idea.

Share this post


Link to post
Share on other sites

park it next to shlammed's car before you torch it and put it out of it's misery. sorry bill.

Share this post


Link to post
Share on other sites

park it next to shlammed's car before you torch it and put it out of it's misery. sorry bill.

 

Made my fucking day... Come drink beer with me, Chris!

Share this post


Link to post
Share on other sites
Sign in to follow this  

×