Jump to content
battleaxe

Curse of the Cressida

Recommended Posts

Going to see if rotors and pads are available for it this week so i can throw those in. The fucking starter still clicks. All grounds are good, gotta take it for warrenty but no time before Friday. Still taking this ship to the bbq

Share this post


Link to post
Share on other sites

314hp at 13psi. Mystery JDM ECU with safcII..It was not cooperating. Going to grab some 550s and put my haltech in and make actual power, but currently it does burnies so that's cool

Share this post


Link to post
Share on other sites

how bad did this thing scrape on the ferry? I seem to remember the ferry ramps are pretty nutty.

Share this post


Link to post
Share on other sites

Like nothing. Top deck too. Maybe tide was in or out iunno. I have tons of clearance. Oil pan is like 6 inch from ground. I touched exhaust but that was it.. And little lip. But I had me and another person as well as tons of tools. And on way home all that plus 4 wheels and less problems. Perfect commuter

Share this post


Link to post
Share on other sites

i forgot i had taken a few pics. this was before i went on the mainland trip to get it tuned, went through sun cloud and rain in the span of an hour and back again, felt good to head up to the mountain top and then i did a whole J turn at the top and headed home and filled it up. looking at other pics of this, im going to paint the rockers for the time being. saw a markII jzx81 for the first time in a long time and looked at all the differences...man...their side molding are sooo much nicer..among everything else.

 

yR6BrkD.jpg

 

then here it is on the dyno

 

U9doBFb.jpg

 

heres the dyno graph from the run before we did 314

 

QZokoXO.jpg

 

i polished the supra this past weekend. found my alternator is dead, and my random spare is also dead, so i grabbed another one and will put that in when i get back from work. made a better solution to the non existent wiper blade inserts that dont exist any more. took a spare s13 wiper and cut the end off and welded it to the arm, which makes it accept all modern wiper blades with that J hook. por15'd all the rust so now when i wash it i dont get a mit full of rust. thats the entire reason i did it, i doubt it will do anything to the rust lol, but at least its black and now hopefully the rust rings of years gone by wont weep all over my paint, so should stay looking alright for more than a hour. raised it 1/4inch so now i have a 1/4 rake forward still. the kaaz also showed up the other day and thats about it for things i plan to do to this ... really need to skid it, fucking 2yrs... well, to be fair, i made it 'better' and fixed a lot that i broke or didnt finish, bought a house and gf lost her job for about 4-5months so its been an interesting 2yrs..in any case

 

1OcvZry.jpg

Share this post


Link to post
Share on other sites

I normally only say this to women,

Nice pair !

Share this post


Link to post
Share on other sites

Bring the supra to the next block party.I love that car man!

Share this post


Link to post
Share on other sites

I appreciate the kind words, especially from Gordo. My plan is to bring the supra to the next one Tore.

 

Put a new alternator in the supra, oddly the connectors were mirrored some how and the plug was on the opposite side, and at max adjustment the belts just tightened enough. They still have bright lettering on them, they're not too old. So it charges now. I made the gaps bigger on the plugs, cleaned up the plug wires, put a new air filter on as the old one wore a hole through it from a tab I made to hold the fuse box, so I modded that too. Idles down at 800rpm finally. It's always had this weird stuck idle, then you blip the throttle and it goes back down, even when it was stock. Thought it was the cable links for throttle before but now I think it's the throttle plate in the afm that gets stuck. Lubed the throttle as well so it's more free, keeps getting stiff.

 

Last thing to do is mod the outer tie rod so I can get more adjustment. I feel it's still toed in and that's as short as they'll go, don't want to align it and not be able to. Currently I'm really happy with it and hope it drives decent. Going to swap insurance from Cressida to supra as we have a drift event in the 22nd I'd like to skid at.

Share this post


Link to post
Share on other sites

modded the supras tie rods. that's ready to go now.

got the Cressida aligned tonight, now at -4.6 camber in the front and a little toe in, and -3.8 in the rear with 0 toe. felt great going home (20mm extended LCAs)

the rack is still stiff and both seals on the rack leak into the boots. not sure if this is due to the solenoid I removed or if this once "de powered x7 rack" (it was looped and not dismantled) is just hooped, or what. it feels like a manual steer rack. even with roller bearings on the springs in the front and less camber, its still dumb. albeit, the cast is at around 9..or high 8's, have to look at the sheet.

 

might swap insurance to the supra this weekend and then drive the supra around and get that aligned next week and finally work those last few kinks out and load up tires and have at it for an event and see if the diff shits itself. the kaaz is next on the docket for that car and then I hope that's it. other than adding power steering to it again, I don't forsee doing anything until the motor shits itself then ill start the SR swap.

 

all that being said, as I moved all the cars around this weekend and finally put the s13 in the garage to work on, it baffles me how ppl cant drive s13s good. I literally hopped in the car and can do whatever I want it to do. also the steering in that car feels like a Cadillac even though that rack also leaks.

Share this post


Link to post
Share on other sites

finally got the supra aligned, feels great.
so with 20mm longer LCA's and short knuckles with MKIII inner tie rods and MKII outers (shaved down 1/4inch)
I had -3.7 camber with a tiny bit of toe in of 0.05 and 5.5 castor with the factory castor rods and the top plates (angled like the cressidas)

in the rear with the risers and modded LCAs, had -5.3 camber and 0 toe.
thats tucking most of the tire on a 205/50/15, almost rim as well

15x9 -13 wheels all around, next to no clearance in the front

really thinking about putting my PS back in as the steering is still quite heavy.
the throttle plate is also sticking so i have to see what the deal is inside. didn't see anything when i changed the filter

other than that, very happy with it. its even pleasant to drive

Share this post


Link to post
Share on other sites

The max caster I got on my x7 with xm arms I was able to get was 5.1, I could probably remove a washer get a tad more. But jealous non the less haha. And hooleee 5.9 in the rear!!

 

Glad everything rolling smoothish for you!

Share this post


Link to post
Share on other sites

I could get less castor, I just didn't know where to set it, didn't have factory specs. Going to try this and see how it goes. 5.3 rear :P with camber plates could go lower camber, but whatever. I wanted max camber to fit the big Wats but I won't be able to without heavy mods and I want to keep stock body. Going to try and fit the big Wats to my truck because most of the guards are rust

Share this post


Link to post
Share on other sites

Stunce durft car does a tire burn, click for more insane pictures.

 

It's nice having multiple cars to do different stuff to. S13 is getting g a make over and raising it up. Got some chubby re71rs for it to do a grip

Share this post


Link to post
Share on other sites

Ya I guess you probably don't plan to only drift your MA if at all. From my understanding you want to run as much caster as possible (until you start to overcenter) for drifting since it helps with steering return. I see a lot of the x8 guys get 7+ degrees

 

I know for x7 the acceptable factory caster range is pretty wide: 4.1-5.6 degrees. I was stoked I was able to get to -2.5 on my rear as much positive as possible with the brackets =(

Share this post


Link to post
Share on other sites

X8 and s13 both run much higher castor from factory, the supra seems to be a lot like the ae86. Which run low castor...not sure if it was a coming on the times to make them better or just because of the system they're in. Iunno

Share this post


Link to post
Share on other sites

ok

 

heres some from the other week when i moved the cars around and finally put the s13 in the garage.

took paul from shadynasty around today to go out to the sticks with the supra. still has a sticky throttle. not sure whats going on. i took the filter and afm off...keep thinking its pulling and pushing too much air, as when its off the throttle feels fine.

 

QyeY5km.jpg

 

thats my civic with the bits

 

hNAWHNN.jpg

 

d21 seems fine now a days. has all belltech drop knuckles, 3inch drop blocks and their shocks as well. has 15x8 -5 OZ rallye, ka24e bits from the s13, supras old metal rad, misc junk yard parts and a tom's bucket seat and a personal steer wheel. had that ol gal for just shy of 12yrs i think now

 

E6ZVOsv.jpg

 

the cressida obviously

 

X1cShjM.jpg

 

and the s13 and where its at currently with doing the new ic and piping and such. just took apart and put back together the coilovers and going over everything, been 10yrs of neglect and just drifting with just your basic maintenance and fixing the broken parts i break

Share this post


Link to post
Share on other sites

What would you like to know? I have a bunch of pictures of it. It's taken me all over the pnw. Had 665xxxkms on it. Original ka24e. Was a Nissan parts truck for most of its life. I'm the 3rd? Owner. S13 intake manifold, misc s13 pieces. S13 exhaust manifold with a full exhaust made from scraps with a greddy evo muffler at the end. Super simple. Some day I'll put s13 suspension in front and back with 4 lug so I can run my large Wats

Share this post


Link to post
Share on other sites

jesus i thought i had a car problem

Share this post


Link to post
Share on other sites

6 cars and 2 bikes, I'm an idiot.

 

Took the supra for skids tonight....holy fuck. I missed this thing. Even with grippy tires this thing was a hoot. Wrecked my daily tires and everything. Going to check over the bolts and re seal my diff as it was leaking a little bit. Going to go over the oil cooler lines as well, I saw some fluid but did the feel like oil. Gunna look it over this weekend. Pictures and video might show up, or not. Doesn't matter. Felt reeeeal good to get back out there. Honestly feels very similar to my s13 now. Still hard to skid with the manual steers but felt good. Fell in love with it all over again.

Share this post


Link to post
Share on other sites

few photos turned up today. oof

i think thats my gf in the passenger seat. she hasn't sat with me while drifting since like 2011 when we started dating. didn't scream this time, lol

 

MsRo5hM.jpg

 

mFDMnow.jpg

 

HNsq3DE.jpg

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×