Jump to content
battleaxe

Curse of the Cressida

Recommended Posts

I don't have a clue on that one.

That is why I am going to the MR-S pump, because it as a built in controller, that only needs a signal from the trans speed sensor, and automatically varies output.

 

I would suggest buying the factory manual for that car, and read up on what kind of signals make it work.

Then see if you can adapt something like an RPM switch to shift from lots of assistance to minimal assistance.

Share this post


Link to post
Share on other sites

my JZX81 has a specific controller for the PPS. has a "GT" sticker on it and a different PN. I wonder if it just has a different progressive curve to make it feel stiffer and therefor "sportier."

Share this post


Link to post
Share on other sites

i thought mark (aphxero) did it with his or had mentioned this before?

 

i have a x7 rack in my x8, with the x8 solenoid. when deleted at the rack it was not working (duh) i would imagine an aftermarket ecu could be utilized to control this at the rack, if you had a speed sensor, or could go off rpm even. im sure theres many ways to try and go about this...theoretically, as i have never futz'd with anything other than an oem ecu cause im basic

Share this post


Link to post
Share on other sites
finally hit the slopes again, even though i wasnt feeling very good, still did a number of laps and then drove er home. also going to go na 2j, as a friend of his got rear ended and we are going to make use of the bits. heres some snaps a friend took at the event. clutch pedal adjustment still needs to continue as shifting into second in the higher revs, she doesnt like..at all. even after 2 amsoil trans fluid changes.


DLw3Lm5.jpg


70JVuHT.jpg


sIlVai4.jpg


X7eHPwI.jpg

Share this post


Link to post
Share on other sites

Love the last pic of the ass squat.

Looks like a really fun day.

Share this post


Link to post
Share on other sites

did some more skids monday night, refreshing.

was good til a tire exploded and broke the bottom of my right rear flare and my fender trim went and got broken...then took apart what "metal" /rust was the lower 1/4 lol. oh well, got most of the pieces. ill look into that soon

 

8sRbpl0.jpg

 

gO983yI.jpg

Share this post


Link to post
Share on other sites

Ass like that comes at a price

Share this post


Link to post
Share on other sites

is300 ps pump is not the same as 1jz non vvti. sticks out about 1-2 teeth. i flipped the pulley, no work belt problems.

as for the intermittent start...when i get a new multi meter ill check it...but the goal sooner than later is to pull the harness and go through every single wire and see what the fuck happened and fix it/replace it and then run the haltech and get it retuned and should make close to 400. hopefully in that mix i will find the issue if not sooner. got a lot of things i want to do but id rather drive it and drift it than deal with the stupid problems that arent driveability problematic

Share this post


Link to post
Share on other sites

odd to think a 2j pump wouldn't work on a 1j?
Did you try the 1j pulley on the is300 pump? (I doubt it's different)

More on the PPS, if I completely unplug PPS, will it steer like shit?

Share this post


Link to post
Share on other sites

i dont have a 2j pulley to have tested. i had a oem 1jz pulley and the DM one. DM one was straight and lighter so i chucked it on.

i had the rack unplugged and had a block off plate, and it was terrible at low speed, especially with no LCAs and 18s, at highway speed was totally fine...was horrible for drifting. i put the goober back in and its fine at all speeds.need to start driving it again and go through all the little things i may have missed since last time. looking forward to dropping the subframe and putting all the adjustable arms and subframe bushings in and then make up some strengthen plates and then paint it all...and take out the bullshit stock stance bushings in the coils and find some sphericals to press in....oh...a never ending list of basic stuff to make it "normal" and "drive good"

Share this post


Link to post
Share on other sites
done drifting this thing for a while. going to check it over before i get it ready for motor swap (late in year if this year at all) felt a little down on power, or over gripped last event on my last pair of tires, was a unique layout so hoping the lack of power was just in my head. got a nice photo out of it though :)


FMfBldo.jpg

Share this post


Link to post
Share on other sites

done driving the supra. took the ZIII's off the front and gave it a quick bath. put my good tread 17s on the cressida, has re71's on the front and some slightly smaller falken whatevers in the back...i dont mind this photo, but i much prefer the 18s on it with the tiny tires. im a big fan of chubby tires, but i dont feel it suits this car in the least. its a nice change though. drove it last night and didnt want to start after a 45min-hr drive then i got a full tank of gas. decided not to start, i walked home after everyone i talked to had no jumpers (theyre in my bag in the car now) got gf off the sleeping couch at 1145 and went to pick it up. going to have to figure this out as its a hazard now. rack still has a dead spot in it, going to tighten the pinion gear and see if it helps, if not im going to through my x8 rack back in and get some new rack bushings as mine are the "conversion bushings" one x7 and one x8. the back still has a vibration at speed, whatever 3000-3500rpm or 5th gear is...not sure if driveshaft is not balanced or if the ...all the bushings are toast...or a combination of things. its sort of a safety thing currently as it keeps me from going mach10 everywhere. shifting from 2nd to third is not great with the long shifter, going to try a smaller knob and see if it helps, not sure why the lack of wanting to go in third. le sigh....maintenance and going though everything ... i remember why so many ppl give up on these cars..and projects in general.

 

nfwFaXD.jpg

 

rbCCPtj.jpg

Share this post


Link to post
Share on other sites

Hey Chris I hope your bringing the X8 to the block party?

You should bring the supra to.

Share this post


Link to post
Share on other sites

I'm brining both mine! I think... still trying to figure out someone to drive one of them....

Share this post


Link to post
Share on other sites

not going to block party. its on a sunday and i work monday :/

also really want to sort the shitty starting issue on the cressida. i have a bit of a list for the cressida to make me feel good about going anywhere. after it left me stranded, luckily close to home where i could sort it, i didnt feel great about trying to do anything but a drive in it.

supra has no insurance on it. oh wells

Share this post


Link to post
Share on other sites

a buddy of mine is going to help me sort out this shitty starting issue. did new relay and ignition, nope. throwing money didnt seem to work yet. hes way smarter than i am and we will actually test what may be the issue...and then probably just make a new circuit...until i tear all the wiring out and put it in the bin.

 

painted the s13 engine bay and have started reassembly

 

from

KM9u19J.jpg

Zn5UfRd.jpg

 

 

to

MhhMFjx.jpg

X2tSUba.jpg

 

it has a lot more in there now...but now it moves and i can clean the shop.

Share this post


Link to post
Share on other sites

Mmm so glad I joined Zilvia.net. Haha. Engine bay looks killer! I love how clean and tidy it is. I really want an oil filter relocation like you have.

Share this post


Link to post
Share on other sites

Because jz oil filters are located in the most inconvenient spot possible...

 

Car looks good man, I regret not bashing my tubes, mine rub even on my bitch spec wheels/height =(

 

I'm coming out for an event on the Island next year, nothing gonna get in my way! haha

Share this post


Link to post
Share on other sites

Jz oil filters can be in a shitty spot with the oil warmer still on depending on motor. I took my warmer off and have a sandwich in there, super easy to get to.

 

Will be nice to have you experience it first hand here. I got a bed u can sleep on if you need. I'm 7min from the track as well in case something happens.

Share this post


Link to post
Share on other sites

Would be less messy on a filter change if you mounted it down.

But looking good, as far as 240s can, except for the engine...

Why not a 6 ?

Share this post


Link to post
Share on other sites

Gordo, if it's anything like my mom's old Subaru, oil changes are never messy with the filter mounted upside-down. Gravity keeps oil drained from the filter when the car is not running.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×