Jump to content
Big Fuckin Shooter

Misfiring Cunt

Recommended Posts

Alright, so ever since getting my car running again this summer it's been having random misfiring issues and hitting a major stutter under boost at about 4-4500 RPM. I've pretty much reached the end of my rope with trying to diagnose what the fuck the issue is, so I figured I'd ask here to see if you guys had any other ideas of what it could be before I burn it to the ground.


Here's the background on the car:

1991 JZX81 Mark II

1.5JZ (GTE block)


440cc Aristo Injectors w/ stock FPR & JZA80 TT fuel pump


Things I have already tried to solve the issue:

New BKR7E plugs gapped to 0.28

New Aftermarket Coilpacks, heatshrinked (also tried running it on an OE set which are known to be good)

Can't isolate the miss by pulling coilpack plugs, it seems completely random

Checked Coilpack plugs/wiring - good

Checked Injector plugs/wiring - good

Compression tested cylinders 1-6: 153, 153, 166, 167, 164, 153

Pressurized the intake system to 100 psi, no boost or vacuum leaks

Swapped ECU and Igniter for known good ones

Checked cam and crank sensors, cam sensors were in spec (F - 1301 ohms, R - 1260), crank was out of spec (1453), so I replaced it with a spare (2230).

Grounded NSW and STA pins on the ECU

Mechanical timing marks are lined up correctly

Not throwing any codes besides Oxygen sensor (Code 21) - EDIT: Since changing crank sensor to one within spec it is now throwing code 13.

Have not tried another MAP sensor yet.



Car idles relatively smooth when it's cold, but as soon as it gets warm it misses pretty badly. When revved up to around 4k ish in neutral the engine hits a misfire/hiccup.

Under load it hits a bad stutter at 4-4500 and ~7 PSI, feels kind of like boost cut but harder. Holds 10 PSI after getting past the stutter up to redline but feels like it's still stuttering, and like something is holding it back.

Runs fine when just cruising, no hint of a miss under 4k RPM (although it is running kind of lean).

Ignition timing shows 35-45* advanced when engine is cold, 50-60* advanced when warm which is way too fucking high.

AFR is between 15-16 at idle, 14-15 cruising, 10 or richer under boost.

Plugs are clean white/grey in colour, little to no soot, so its lean as fuck.


I don't know what else to check to diagnose the issue. My next plan of attack is to just find an unmolested JZZ30 Soarer harness and swap it in since my harness is 25 years old and has been converted to run 3 different setups and cut/spliced/soldered so many times that something could be fucked, although I've checked it pretty thoroughly and can't seem to find anything obvious.



Share this post

Link to post
Share on other sites

Holy fuckin shit. IDL1 wasn't populated either, the person who previously assembled my harness while I was too busy with school pinned it into one of the body connectors.

Pinned it into the ECU, didn't seem to change much in terms of running at idle. Still has a miss, timing is still at 50* cold. However, I now have a code 13, which is fucked because I just swapped an out of spec crank sensor for an in spec one.


The saga continues.


EDIT: Also forgot to mention, sometimes the car fires up on the first or second turn of the starter, and other times it feels like it's trying to fire on the compression stroke and takes a few more cranks of the starter to actually start. Seems more and more like an ignition timing related issue.

Share this post

Link to post
Share on other sites

An out of spec water temp sensor or intermittently failing water temp will fuck with ignition fire

Share this post

Link to post
Share on other sites

After checking for continuity between the grounds for the cam and crank sensors the crank sensor was wired backwards. Misfire seems to be gone. Haven't driven it yet to see if IDL1, NSW or STA fixed the 4k RPM stutter.


However, timing is still way advanced. I'm seeing 30-35* at idle, 25* in diag mode. Any ideas what else to check next? Cam and crank sensors all tested within the acceptable range of resistance.

Share this post

Link to post
Share on other sites

Problem solved. Car is a beast now.


I didn't realize that checking timing by the loop of wire inside the igniter connector shell would give me incorrect readings. Checked timing with a spark plug wire between the first coil and plug and it was at about 15*.



Share this post

Link to post
Share on other sites